Tutorial - Create a Switchboard Action to be used in a Process Plan

Background

Process Plans allow you to run profiles, checks and fixups, but you can also create your own actions to be executed as part of the processing. How are these actions created? In this tutorial I will show you  how to create a Switchboard action that will generate thumbnail images for each page of a processed PDF file.

Applications

Instructions

  1. Open pdfToolbox Desktop.
  2. Go to the Switchboard panel.
  3. Click on the category "Document".
  4. Choose "Image Export".
  5. Configurate the image settings as below:


     
  6. In the bottom left corner, click on the action button and choose "Create new switchboard action..."
    The "Create action" dialog displayed to create a new action.
  7. Enter a short descriptive name and a description explaining what this particular action does. 


     
  8. Click "OK".
    The action now appears in the action menu of the Switchboard when you go to the "Image Export" section. You can use these preconfigured actions to quickly switch between different settings you frequently use in the Switchboard. This action will now also automatically appear in the list of actions when you're building a Process Plan.
  9. To set up a Process Plan, go to "Tools > Profiles".
  10. In the top right corner, click on the action button and choose "Create New callas pdfToolbox Process Plan".
    The "New Process Plan" dialog displayed.
  11. In the "Sequence" panel, double click "Action".
    The "Action" section is added to the Process Plan.
  12. In the "Name" list choose the newly created "Create thumbnails" action.
  13. Save the process plan as "Create 100 pixels wide thumbnails".
  14. Click "OK".
    The process plan is saved in the predefined Profiles list.
  15. To open the attached input PDF file in pdfToolbox to apply the created process plan, go to "File > Open".
  16. Browse to the folder where the attached input PDF file is located.
  17. Select the file and click "Open".
    The input PDF file is imported in pdfToolbox.
  18. Go to "Tools > Fixups".
    The predefined fixup list is displayed.
  19. In the top right corner, in the search box, search to "Create 100 pixels wide thumbnails".
  20. Select the process plan "Create 100 pixels wide thumbnails" and click "Analyze and fix".